"The nice thing about standards is that there are so many to choose from."
All articles
Last comments
Go to your settings -> themes Press the icon button and change it, in this case, to flat-remix
use this for example https://imgur.com/ then just insert link to the page with picture
Shekin, thanx for your answer. I'm not using Facebook or any other spying (social) sites. Can I somehow uploaded that screen here? Probably not.
Give the right for file sudo chmod +x amd-driver-installer-15.20.1046-x86.x86_64.run
«    October 2016    »
» » Install latest Maxthon Cloud Browser linux Mint

Install latest Maxthon Cloud Browser linux Mint

Install latest Maxthon Browser via PPA on linux Mint

Maxthon Cloud Browser (Linux) browser based on Chromium engine (WebKit), with the possibility of using "cloud" technology. Maxthon is the epitome of international experience in the field of view of web pages, and is intended for use on personal computers and mobile devices

Sorry for the spelling and phonetic errors in the text.
Owner and main writer of MintGuide.org is not a native English speaker.

some of the features:
- mouse gestures to control the browser
- improved application menu with quick access to favorites, history, downloads, and settings,
- sync bookmarks, history, passwords, open tabs via the cloud
- block unwanted advertising using automatically installed the AdBlock extension
- support for all extensions that you can install from Google Chrome.

Install latest Maxthon Cloud Browser via PPA on linux MintInstall latest Maxthon Cloud Browser via PPA on linux Mint


Installation into Linux Mint from DEB package:

Download the latest version from the official site

Install latest Maxthon Cloud Browser on linux MintInstall latest Maxthon Cloud Browser on linux Mint

Double click on the downloaded package and click Install.

Good Luck!!!


Related articles


  1. Luis
    He usado Maxthon por mucho tiempo en Windows, pero me pase a Linux Mint,use una primera version de Maxthon para linux luego vino la versión 1,0.0.53,funcionó bien por un tiempo,ya no lo he podido usar mas,no traduce las páginas,algunos videos no se ven,unicamente uso los marcadores que tenia en Maxthon en otro navegador,ha pasado ya bastante tiempo y no lo han podido arreglar.....
  2. Shekin
    sudo apt install -f

    if it will delete maxthon - wait new version LM
    Now i cannot check, sorry. I am on work with very bad internet speed
    x64 Linux Mint 18 cinnamon
  3. Bart
    I have the same problem with ubuntu 16

    The following packages have unmet dependencies:
    maxthon-browser-STABLE: Depends: libgcrypt11 (> = 1.4.5) but it is not installable
    E: We were unable to correct problems, you have held broken packages.

    Besides that it has strange not downloadable images, and weird html facts.

    I could not install
  4. exequiel
    Los siguientes paquetes tienen dependencias incumplidas:
    maxthon-browser-stable : Depende: libgcrypt11 (>= 1.4.5) pero no es instalable
    E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

    No pude instalarlo
  • bowtiesmilelaughingblushsmileyrelaxedsmirk
Login via